What’s Vulnerable › Vulnerabilities
CVE-2022-49314: tty: Fix a possible resource leak in icom_probe
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: tty: Fix a possible resource leak in icom_probe When pci_read_config_dword failed, call pci_release_regions() and pci_disable_device() to recycle the resource previously allocated.
Affected products
- Linux kernel: before 4.9.318; from 4.10 before 4.14.283; from 4.15 before 4.19.247; from 4.20 before 5.4.198; from 5.5 before 5.10.122; from 5.11 before 5.15.47 — fixed in 4.14.283, 4.19.247, 4.9.318, 5.10.122, 5.15.47, 5.17.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.283, 4.19.247, 4.9.318, 5.10.122. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/23e155b51d403c0ccedc60c0d6c3c452afed07fe
- https://git.kernel.org/stable/c/5f9b2e4ca88cab1a96b86ecd45544e488ca43faf
- https://git.kernel.org/stable/c/8c014373f178a4f13a08e045ef63bdb23f62e892
- https://git.kernel.org/stable/c/9a8305f357a8d03698fc7bc855ff9c6865d5486b
- https://git.kernel.org/stable/c/a2df0b4d080cc770b4da7bff487048c803dfd07e
- https://git.kernel.org/stable/c/cb7147afd328c07edeeee287710d8d96ac0459f5
- https://git.kernel.org/stable/c/d703d912a985c1c5b50dd38c3181fc3540fa77cb
- https://git.kernel.org/stable/c/ee157a79e7c82b01ae4c25de0ac75899801f322c
- https://git.kernel.org/stable/c/f4c836d90da1ece88905d62ce2ce39a962f25d1a
Get alerted when CVE-2022-49314 or the next vulnerability affects your stack