What’s Vulnerable › Vulnerabilities
CVE-2022-4933: ATM Consulting dolibarr_module_quicksupplierprice interface.php upatePrice sql injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability, which was classified as critical, has been found in ATM Consulting dolibarr_module_quicksupplierprice up to 1.1.6. Affected by this issue is the function upatePrice of the file script/interface.php. The manipulation leads to sql injection. The attack may be launched remotely. Upgrading to version 1.1.7 is able to address this issue. The patch is identified as ccad1e4282b0e393a32fcc852e82ec0e0af5446f. It is recommended to upgrade the affected component. VDB-223382 is the identifier assigned to this vulnerability.
Affected products
- ATM Consulting dolibarr_module_quicksupplierprice: before 1.1.7 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: ATM Consulting dolibarr_module_quicksupplierprice 1.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/ATM-Consulting/dolibarr_module_quicksupplierprice/commit/ccad1e4282b0e393a32fcc852e82ec0e0af5446f
- https://github.com/ATM-Consulting/dolibarr_module_quicksupplierprice/pull/21
- https://vuldb.com/?ctiid.223382
- https://vuldb.com/?id.223382
- https://github.com/ATM-Consulting/dolibarr_module_quicksupplierprice/commit/ccad1e4282b0e393a32fcc852e82ec0e0af5446f
- https://github.com/ATM-Consulting/dolibarr_module_quicksupplierprice/pull/21
- https://vuldb.com/?ctiid.223382
- https://vuldb.com/?id.223382
Get alerted when CVE-2022-4933 or the next vulnerability affects your stack