What’s Vulnerable › Vulnerabilities
CVE-2022-4935: WCFM Marketplace <= 3.4.11 - Missing Authorization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-05 · updated 2026-06-17
- Weakness: CWE-89
Description
The WCFM Marketplace plugin for WordPress is vulnerable to unauthorized modification and access of data in versions up to, and including, 3.4.11 due to missing capability checks on various AJAX actions. This makes it possible for authenticated attackers, with minimal permissions such as subscribers, to perform a wide variety of actions such as modifying shipping method details, modifying products, deleting arbitrary posts, and privilege escalation (via the wp_ajax_wcfm_vendor_store_online AJAX action).
Affected products
- wclovers WCFM Marketplace – Multivendor Marketplace for WooCommerce: before 3.4.12 — fixed in 3.4.12
How to fix
Upgrade to a fixed version: wclovers WCFM Marketplace – Multivendor Marketplace for WooCommerce 3.4.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2630696%40wc-multivendor-marketplace&new=2630696%40wc-multivendor-marketplace&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/85730e9b-c5da-473c-a324-891c5c9f7ba3?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2630696%40wc-multivendor-marketplace&new=2630696%40wc-multivendor-marketplace&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/85730e9b-c5da-473c-a324-891c5c9f7ba3?source=cve
Get alerted when CVE-2022-4935 or the next vulnerability affects your stack