What’s Vulnerable › Vulnerabilities
CVE-2022-49362: NFSD: Fix potential use-after-free in nfsd_file_put()
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Fix potential use-after-free in nfsd_file_put() nfsd_file_put_noref() can free @nf, so don't dereference @nf immediately upon return from nfsd_file_put_noref().
Affected products
- Linux kernel: from 5.18 before 5.18.4; 5.19-rc1 — fixed in 5.18.4
How to fix
Upgrade to a fixed version: Linux kernel 5.18.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/261eabe19cb28e4a8587a4442d257b543d7c2d57
- https://git.kernel.org/stable/c/333dcc94ebf53f79f3dc0e7a7c16700bc7ff7e57
- https://git.kernel.org/stable/c/ada1757b259f353cade47037ee0a0249b4cddad3
- https://git.kernel.org/stable/c/b6c71c66b0ad8f2b59d9bc08c7a5079b110bec01
Get alerted when CVE-2022-49362 or the next vulnerability affects your stack