What’s Vulnerable › Vulnerabilities
CVE-2022-49365: drm/amdgpu: Off by one in dm_dmub_outbox1_low_irq()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-193
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu: Off by one in dm_dmub_outbox1_low_irq() The > ARRAY_SIZE() should be >= ARRAY_SIZE() to prevent an out of bounds access.
Affected products
- Linux kernel: from 5.16 before 5.17.15; from 5.18 before 5.18.4 — fixed in 5.17.15, 5.18.4
How to fix
Upgrade to a fixed version: Linux kernel 5.17.15, 5.18.4. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/607c5cd1a08e196d9f2bd3b25a8083ed27ad7ceb
- https://git.kernel.org/stable/c/a35faec3db0e13aac8ea720bc1a3503081dd5a3d
- https://git.kernel.org/stable/c/b0808b7a04157b3f56e919f27023fec37a075fad
- https://git.kernel.org/stable/c/ec9ec3bc08b18c5b1b2feafd306ea7c348013898
Get alerted when CVE-2022-49365 or the next vulnerability affects your stack