What’s Vulnerable › Vulnerabilities
CVE-2022-49404: RDMA/hfi1: Fix potential integer multiplication overflow errors
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/hfi1: Fix potential integer multiplication overflow errors When multiplying of different types, an overflow is possible even when storing the result in a larger type. This is because the conversion is done after the multiplication. So arithmetic overflow and thus in incorrect value is possible. Correct an instance of this in the inter packet delay calculation. Fix by ensuring one of the operands is u64 which will promote the other to u64 as well ensuring no overflow.
Affected products
- Linux kernel: from 4.3 before 4.9.318; from 4.10 before 4.14.283; from 4.15 before 4.19.247; from 4.20 before 5.4.198; from 5.5 before 5.10.121; from 5.11 before 5.15.46 — fixed in 4.14.283, 4.19.247, 4.9.318, 5.10.121, 5.15.46, 5.17.14
How to fix
Upgrade to a fixed version: Linux kernel 4.14.283, 4.19.247, 4.9.318, 5.10.121. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06039d8afefdbac05bcea5f397188407eba2996d
- https://git.kernel.org/stable/c/252f4afd4557a2e7075f793a5c80fe6dd9e9ee4a
- https://git.kernel.org/stable/c/31dca00d0cc9f4133320d72eb7e3720badc6d6e6
- https://git.kernel.org/stable/c/3f09ec80f115d2875d747ed28adc1773037e0f8b
- https://git.kernel.org/stable/c/79c164e61f818054cd6012e9035701840d895c51
- https://git.kernel.org/stable/c/8858284dd74906fa00f04f0252c75df4893a7959
- https://git.kernel.org/stable/c/a89cb7ddf6a89bab6012e19da38b7cdb26175c19
- https://git.kernel.org/stable/c/ef5ab2e48a5f9960e2352332b7cdb7064bb49032
- https://git.kernel.org/stable/c/f93e91a0372c922c20d5bee260b0f43b4b8a1bee
Get alerted when CVE-2022-49404 or the next vulnerability affects your stack