What’s Vulnerable › Vulnerabilities
CVE-2022-49405: staging: r8188eu: prevent ->Ssid overflow in rtw_wx_set_scan()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: staging: r8188eu: prevent ->Ssid overflow in rtw_wx_set_scan() This code has a check to prevent read overflow but it needs another check to prevent writing beyond the end of the ->Ssid[] array.
Affected products
- Linux kernel: from 5.15 before 5.15.46; from 5.16 before 5.17.14; from 5.18 before 5.18.3 — fixed in 5.15.46, 5.17.14, 5.18.3
How to fix
Upgrade to a fixed version: Linux kernel 5.15.46, 5.17.14, 5.18.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/476bfda0be0f9669add92bff604ca78226cf53d1
- https://git.kernel.org/stable/c/ac2eab7de458f5e1210ce1237afab40a307075c8
- https://git.kernel.org/stable/c/bc10916e890948d8927a5c8c40fb5dc44be5e1b8
- https://git.kernel.org/stable/c/c4bd6b72df4f01aa866ceb298466d6d07a6bd525
Get alerted when CVE-2022-49405 or the next vulnerability affects your stack