What’s Vulnerable › Vulnerabilities
CVE-2022-49410: tracing: Fix potential double free in create_var_ref()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: tracing: Fix potential double free in create_var_ref() In create_var_ref(), init_var_ref() is called to initialize the fields of variable ref_field, which is allocated in the previous function call to create_hist_field(). Function init_var_ref() allocates the corresponding fields such as ref_field->system, but frees these fields when the function encounters an error. The caller later calls destroy_hist_field() to conduct error handling, which frees the fields and the variable itself. This results in double free of the fields which are already freed in the previous function. Fix this by storing NULL to the corresponding fields when they are freed in init_var_ref().
Affected products
- Linux kernel: from 4.17 before 4.19.247; from 4.20 before 5.4.198; from 5.5 before 5.10.121; from 5.11 before 5.15.46; from 5.16 before 5.17.14; from 5.18 before 5.18.3 — fixed in 4.19.247, 5.10.121, 5.15.46, 5.17.14, 5.18.3, 5.4.198
How to fix
Upgrade to a fixed version: Linux kernel 4.19.247, 5.10.121, 5.15.46, 5.17.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/058cb6d86b9789377216c936506b346aaa1eb581
- https://git.kernel.org/stable/c/37443b3508b8cce6832f8d25cb4550b2f7801f50
- https://git.kernel.org/stable/c/4fdfb15e08598711dbf50daf56a33965232daf0e
- https://git.kernel.org/stable/c/99696a2592bca641eb88cc9a80c90e591afebd0f
- https://git.kernel.org/stable/c/bd83ff3bbfb003832481c9bff999d12385f396ae
- https://git.kernel.org/stable/c/c27f744ceefadc7bbeb14233b6abc150ced617d2
- https://git.kernel.org/stable/c/f8b383f83cb573152c577eca1ef101e89995b72a
Get alerted when CVE-2022-49410 or the next vulnerability affects your stack