What’s Vulnerable › Vulnerabilities
CVE-2022-4949: AdSanity < 1.8.2 - Authenticated Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-434
Description
The AdSanity plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'ajax_upload' function in versions up to, and including, 1.8.1. This makes it possible for authenticated attackers with Contributor+ level privileges to upload arbitrary files on the affected sites server which makes remote code execution possible.
Affected products
- Adsanityplugin Adsanity: before 1.8.2 — fixed in 1.8.2
- xen: all versions
How to fix
Upgrade to a fixed version: Adsanityplugin Adsanity 1.8.2. Check the vendor advisory for mitigations.
References
- https://blog.nintechnet.com/critical-vulnerability-in-wordpress-adsanity-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/effd72d2-876d-4f8d-b1e4-5ab38eab401b?source=cve
- http://www.openwall.com/lists/oss-security/2023/11/09/3
- http://xenbits.xen.org/xsa/advisory-443.html
- https://blog.nintechnet.com/critical-vulnerability-in-wordpress-adsanity-plugin/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/effd72d2-876d-4f8d-b1e4-5ab38eab401b?source=cve
Get alerted when CVE-2022-4949 or the next vulnerability affects your stack