What’s Vulnerable › Vulnerabilities
CVE-2022-49512: mtd: rawnand: denali: Use managed device resources
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: mtd: rawnand: denali: Use managed device resources All of the resources used by this driver has managed interfaces, so use them. Otherwise we will get the following splat: [ 4.472703] denali-nand-pci 0000:00:05.0: timeout while waiting for irq 0x1000 [ 4.474071] denali-nand-pci: probe of 0000:00:05.0 failed with error -5 [ 4.473538] nand: No NAND device found [ 4.474068] BUG: unable to handle page fault for address: ffffc90005000410 [ 4.475169] #PF: supervisor write access in kernel mode [ 4.475579] #PF: error_code(0x0002) - not-present page [ 4.478362] RIP: 0010:iowrite32+0x9/0x50 [ 4.486068] Call Trace: [ 4.486269] <IRQ> [ 4.486443] denali_isr+0x15b/0x300 [denali] [ 4.486788] ? denali_direct_write+0x50/0x50 [denali] [ 4.487189] __handle_irq_event_percpu+0x161/0x3b0 [ 4.487571] handle_irq_event+0x7d/0x1b0 [ 4.487884] handle_fasteoi_irq+0x2b0/0x770 [ 4.488219] __common_interrupt+0xc8/0x1b0 [ 4.488549] common_interrupt+0x9a/0xc0
Affected products
- Linux kernel: from 4.17 before 5.10.121; from 5.11 before 5.15.46; from 5.16 before 5.17.14; from 5.18 before 5.18.3 — fixed in 5.10.121, 5.15.46, 5.17.14, 5.18.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.121, 5.15.46, 5.17.14, 5.18.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3830dbdfb9a4aec680e43ed80b9f23db7a88eac9
- https://git.kernel.org/stable/c/3a745b51cddafade99aaea1b93aad31e9614e230
- https://git.kernel.org/stable/c/3c68daf4a368cd9e63ae5a2145c9e4a6f838c166
- https://git.kernel.org/stable/c/87149cf9186201a63f0e0b93d9fa93d480bcb771
- https://git.kernel.org/stable/c/efea1dd176edd17c8252051b7de6957f06efc394
Get alerted when CVE-2022-49512 or the next vulnerability affects your stack