What’s Vulnerable › Vulnerabilities
CVE-2022-49552: bpf: Fix combination of jit blinding and pointers to bpf subprogs.
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: bpf: Fix combination of jit blinding and pointers to bpf subprogs. The combination of jit blinding and pointers to bpf subprogs causes: [ 36.989548] BUG: unable to handle page fault for address: 0000000100000001 [ 36.990342] #PF: supervisor instruction fetch in kernel mode [ 36.990968] #PF: error_code(0x0010) - not-present page [ 36.994859] RIP: 0010:0x100000001 [ 36.995209] Code: Unable to access opcode bytes at RIP 0xffffffd7. [ 37.004091] Call Trace: [ 37.004351] <TASK> [ 37.004576] ? bpf_loop+0x4d/0x70 [ 37.004932] ? bpf_prog_3899083f75e4c5de_F+0xe3/0x13b The jit blinding logic didn't recognize that ld_imm64 with an address of bpf subprogram is a special instruction and proceeded to randomize it. By itself it wouldn't have been an issue, but jit_subprogs() logic relies on two step process to JIT all subprogs and then JIT them again when addresses of all subprogs are known. Blinding process in the first JIT phase caused second JIT to miss adjustment of special ld_imm64. Fix this issue by ignoring special ld_imm64 instructions that don't have user controlled constants and shouldn't be blinded.
Affected products
- Linux kernel: from 5.13 before 5.17.13; from 5.18 before 5.18.2 — fixed in 5.17.13, 5.18.2
How to fix
Upgrade to a fixed version: Linux kernel 5.17.13, 5.18.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4b6313cf99b0d51b49aeaea98ec76ca8161ecb80
- https://git.kernel.org/stable/c/a029b02b47dd5bb87a21550d9d9a80cb4dd3f714
- https://git.kernel.org/stable/c/d106a3e96fca30e44081eae9c27aab28fc132a46
Get alerted when CVE-2022-49552 or the next vulnerability affects your stack