What’s Vulnerable › Vulnerabilities
CVE-2022-49570: gpio: gpio-xilinx: Fix integer overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: gpio-xilinx: Fix integer overflow Current implementation is not able to configure more than 32 pins due to incorrect data type. So type casting with unsigned long to avoid it.
Affected products
- Linux kernel: from 5.14 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/32c094a09d5829ad9b02cdf667569aefa8de0ea6
- https://git.kernel.org/stable/c/6f16a5390640807dde420ee5ccbc4c95577aea6a
- https://git.kernel.org/stable/c/e129e5486b981d324057e6986059f852658b0d00
Get alerted when CVE-2022-49570 or the next vulnerability affects your stack