What’s Vulnerable › Vulnerabilities
CVE-2022-49576: ipv4: Fix data-races around sysctl_fib_multipath_hash_fields.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: Fix data-races around sysctl_fib_multipath_hash_fields. While reading sysctl_fib_multipath_hash_fields, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 5.14 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/36f5b86f309b3b11295d087cd7433f1c897caf94
- https://git.kernel.org/stable/c/548d6678c4a3d43667e59686665f8674b82440a3
- https://git.kernel.org/stable/c/8895a9c2ac76fb9d3922fed4fe092c8ec5e5cccc
Get alerted when CVE-2022-49576 or the next vulnerability affects your stack