What’s Vulnerable › Vulnerabilities
CVE-2022-49577: udp: Fix a data-race around sysctl_udp_l3mdev_accept.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: udp: Fix a data-race around sysctl_udp_l3mdev_accept. While reading sysctl_udp_l3mdev_accept, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 4.11 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.134, 5.15.58, 5.18.15, 5.4.208
How to fix
Upgrade to a fixed version: Linux kernel 5.10.134, 5.15.58, 5.18.15, 5.4.208. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3d72bb4188c708bb16758c60822fc4dda7a95174
- https://git.kernel.org/stable/c/3f2ac2d6511bb0652abf4d7388d65bb9ff1c641c
- https://git.kernel.org/stable/c/cb0d28934ca10f99c47e2c6f451405d6c954fe48
- https://git.kernel.org/stable/c/f39b03bd727a8fea62e82f10fe2e0d753b9930ff
- https://git.kernel.org/stable/c/fcaef69c79ec222e55643e666b80b221e70fa6a8
Get alerted when CVE-2022-49577 or the next vulnerability affects your stack