What’s Vulnerable › Vulnerabilities
CVE-2022-49579: ipv4: Fix data-races around sysctl_fib_multipath_hash_policy.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: Fix data-races around sysctl_fib_multipath_hash_policy. While reading sysctl_fib_multipath_hash_policy, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 4.12 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/21fb844bc1dc1461f5038d655aa1a14f39e13049
- https://git.kernel.org/stable/c/7998c12a08c97cc26660532c9f90a34bd7d8da5a
- https://git.kernel.org/stable/c/918ee6592ab9a2ff5316d06cfd4aaef60ccabec6
Get alerted when CVE-2022-49579 or the next vulnerability affects your stack