What’s Vulnerable › Vulnerabilities
CVE-2022-49580: ipv4: Fix a data-race around sysctl_fib_multipath_use_neigh.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: Fix a data-race around sysctl_fib_multipath_use_neigh. While reading sysctl_fib_multipath_use_neigh, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 4.7 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.134, 5.15.58, 5.18.15, 5.4.208
How to fix
Upgrade to a fixed version: Linux kernel 5.10.134, 5.15.58, 5.18.15, 5.4.208. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/14e996577ed2799a1ed6ffeb71c76d63acb28444
- https://git.kernel.org/stable/c/6727f39e99e0f545d815edebb6c94228485427ec
- https://git.kernel.org/stable/c/87507bcb4f5de16bb419e9509d874f4db6c0ad0f
- https://git.kernel.org/stable/c/b8d345db03b4deffb4f04219a51d3b1e94171b76
- https://git.kernel.org/stable/c/e045d672ba06e1d35bacb56374d350de0ac99066
Get alerted when CVE-2022-49580 or the next vulnerability affects your stack