What’s Vulnerable › Vulnerabilities
CVE-2022-49581: be2net: Fix buffer overflow in be_get_module_eeprom
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-10-15
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: be2net: Fix buffer overflow in be_get_module_eeprom be_cmd_read_port_transceiver_data assumes that it is given a buffer that is at least PAGE_DATA_LEN long, or twice that if the module supports SFF 8472. However, this is not always the case. Fix this by passing the desired offset and length to be_cmd_read_port_transceiver_data so that we only copy the bytes once.
Affected products
- Linux kernel: from 3.18 before 4.9.325; from 4.10 before 4.14.290; from 4.15 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58 — fixed in 4.14.290, 4.19.254, 4.9.325, 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.290, 4.19.254, 4.9.325, 5.10.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/18043da94c023f3ef09c15017bdb04e8f695ef10
- https://git.kernel.org/stable/c/665cbe91de2f7c97c51ca8fce39aae26477c1948
- https://git.kernel.org/stable/c/8ff4f9df73e5c551a72ee6034886c17e8de6596d
- https://git.kernel.org/stable/c/a5a8fc0679a8fd58d47aa2ebcfc5742631f753f9
- https://git.kernel.org/stable/c/a8569f76df7ec5b4b51155c57523a0b356db5741
- https://git.kernel.org/stable/c/aba8ff847f4f927ad7a1a1ee4a9f29989a1a728f
- https://git.kernel.org/stable/c/d7241f679a59cfe27f92cb5c6272cb429fb1f7ec
- https://git.kernel.org/stable/c/fe4473fc7940f14c4a12db873b9729134c212654
Get alerted when CVE-2022-49581 or the next vulnerability affects your stack