What’s Vulnerable › Vulnerabilities
CVE-2022-49587: tcp: Fix a data-race around sysctl_tcp_notsent_lowat.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix a data-race around sysctl_tcp_notsent_lowat. While reading sysctl_tcp_notsent_lowat, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 3.12 before 4.9.325; from 4.10 before 4.14.290; from 4.15 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58 — fixed in 4.14.290, 4.19.254, 4.9.325, 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.290, 4.19.254, 4.9.325, 5.10.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f75343584ee474303e17efe0610bdd170af1d13
- https://git.kernel.org/stable/c/55be873695ed8912eb77ff46d1d1cadf028bd0f3
- https://git.kernel.org/stable/c/62e56cfeb2ae4b53ae9ca24c80f54093250ce64a
- https://git.kernel.org/stable/c/80d4d0c461674eea87f0977e12a2ecd334b9b79c
- https://git.kernel.org/stable/c/91e21df688f8a75255ca9c459da39ac96300113a
- https://git.kernel.org/stable/c/c1b85c5a34294f7444c13bf828e0e84b0a0eed85
- https://git.kernel.org/stable/c/e9362a993886613ef0284c2a4911c6017c97d803
- https://git.kernel.org/stable/c/fd6f1284e380c377932186042ff0b5c987fb2b92
Get alerted when CVE-2022-49587 or the next vulnerability affects your stack