What’s Vulnerable › Vulnerabilities
CVE-2022-49588: tcp: Fix data-races around sysctl_tcp_migrate_req.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix data-races around sysctl_tcp_migrate_req. While reading sysctl_tcp_migrate_req, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 5.10.188 before 5.11; from 5.14 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.11, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.11, 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4177f545895b1da08447a80692f30617154efa6e
- https://git.kernel.org/stable/c/6e569a11eea20a1ccebc3c4e6366bf0574a449e1
- https://git.kernel.org/stable/c/fcf6c6d8aeffebca66f37b17ef1b57112e5e09c1
Get alerted when CVE-2022-49588 or the next vulnerability affects your stack