What’s Vulnerable › Vulnerabilities
CVE-2022-49595: tcp: Fix a data-race around sysctl_tcp_probe_threshold.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix a data-race around sysctl_tcp_probe_threshold. While reading sysctl_tcp_probe_threshold, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 4.1 before 4.9.325; from 4.10 before 4.14.290; from 4.15 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58 — fixed in 4.14.290, 4.19.254, 4.9.325, 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.290, 4.19.254, 4.9.325, 5.10.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/44768749980d53bc01980d9c060f736808d11af0
- https://git.kernel.org/stable/c/92c0aa4175474483d6cf373314343d4e624e882a
- https://git.kernel.org/stable/c/96900fa61777402eb5056269d8000aace33a8b6c
- https://git.kernel.org/stable/c/9b5dc7ad6da1373d3c60d4b869d688f996e5d219
- https://git.kernel.org/stable/c/b04817c94fbd285a967d9b830b274fe9998c9c0b
- https://git.kernel.org/stable/c/d452ce36f2d4c402fa3f5275c9677f80166e7fc6
- https://git.kernel.org/stable/c/f524c3e7f6cdad66b3b6a912cef47b656f8b0de3
- https://git.kernel.org/stable/c/fa5fb2cf9393db898772db8cb897ed5fd265eb78
Get alerted when CVE-2022-49595 or the next vulnerability affects your stack