What’s Vulnerable › Vulnerabilities
CVE-2022-49596: tcp: Fix data-races around sysctl_tcp_min_snd_mss.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix data-races around sysctl_tcp_min_snd_mss. While reading sysctl_tcp_min_snd_mss, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 3.16.69 before 3.17; from 4.4.182 before 4.5; from 4.9.182 before 4.10; from 4.14.127 before 4.15; from 4.19.52 before 4.20; from 5.1.11 before 5.4.208 — fixed in 3.17, 4.10, 4.15, 4.20, 4.5, 5.10.134
How to fix
Upgrade to a fixed version: Linux kernel 3.17, 4.10, 4.15, 4.20. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d8a39feb58910a7f7746b1770ee5578cc551fe6
- https://git.kernel.org/stable/c/0fc9357282df055e30990b29f4b7afa53ab42cdb
- https://git.kernel.org/stable/c/78eb166cdefcc3221c8c7c1e2d514e91a2eb5014
- https://git.kernel.org/stable/c/97992e8feff33b3ae154a113ec398546bbacda80
- https://git.kernel.org/stable/c/fdb96b69f5909ffcdd6f1e0902219fc6d7689ff7
Get alerted when CVE-2022-49596 or the next vulnerability affects your stack