What’s Vulnerable › Vulnerabilities
CVE-2022-49597: tcp: Fix data-races around sysctl_tcp_base_mss.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix data-races around sysctl_tcp_base_mss. While reading sysctl_tcp_base_mss, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 2.6.17 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.134, 5.15.58, 5.18.15, 5.4.208
How to fix
Upgrade to a fixed version: Linux kernel 5.10.134, 5.15.58, 5.18.15, 5.4.208. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/30b73edc1d2459ba2c71cb58fbf84a1a6e640fbf
- https://git.kernel.org/stable/c/4d7dea651b7fe0322be95054f64e3711afccc543
- https://git.kernel.org/stable/c/514d2254c7b8aa2d257f5ffc79f0d96be2d6bfda
- https://git.kernel.org/stable/c/88d78bc097cd8ebc6541e93316c9d9bf651b13e8
- https://git.kernel.org/stable/c/9ca18116bc16ec31b9a3ce28ea1350badfa36128
Get alerted when CVE-2022-49597 or the next vulnerability affects your stack