What’s Vulnerable › Vulnerabilities
CVE-2022-49599: tcp: Fix data-races around sysctl_tcp_l3mdev_accept.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp: Fix data-races around sysctl_tcp_l3mdev_accept. While reading sysctl_tcp_l3mdev_accept, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 4.5 before 5.10.137; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.137, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.10.137, 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/08a75f10679470552a3a443f9aefd1399604d31d
- https://git.kernel.org/stable/c/1d9c81833dec46ccb52a1d0db970fefb7c4fa071
- https://git.kernel.org/stable/c/7d38d86b818104cf88961f3aebea34da89364a8e
- https://git.kernel.org/stable/c/9ba9cd43b5776c27d25e5a32dde9e80bdeb1c6a1
Get alerted when CVE-2022-49599 or the next vulnerability affects your stack