What’s Vulnerable › Vulnerabilities
CVE-2022-49600: ip: Fix a data-race around sysctl_ip_autobind_reuse.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ip: Fix a data-race around sysctl_ip_autobind_reuse. While reading sysctl_ip_autobind_reuse, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 5.7 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.10.134, 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0db232765887d9807df8bcb7b6f29b2871539eab
- https://git.kernel.org/stable/c/611ba70e5aca252ef43374dda97ed4cf1c47a07c
- https://git.kernel.org/stable/c/87ceaa199a72c5856d49a030941fabcd5c3928d4
- https://git.kernel.org/stable/c/fa7cdcf9b28d13aac1eeb34b948db8a18e041341
Get alerted when CVE-2022-49600 or the next vulnerability affects your stack