What’s Vulnerable › Vulnerabilities
CVE-2022-49601: tcp/dccp: Fix a data-race around sysctl_tcp_fwmark_accept.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: tcp/dccp: Fix a data-race around sysctl_tcp_fwmark_accept. While reading sysctl_tcp_fwmark_accept, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 3.16 before 4.9.325; from 4.10 before 4.14.290; from 4.15 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58 — fixed in 4.14.290, 4.19.254, 4.9.325, 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.290, 4.19.254, 4.9.325, 5.10.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/13207f9485b5de68decf296ceb0046f5eabb2485
- https://git.kernel.org/stable/c/1a0008f9df59451d0a17806c1ee1a19857032fa8
- https://git.kernel.org/stable/c/45fc82706a97242539d6b841ddd7a077ec20757b
- https://git.kernel.org/stable/c/526d8cf8824f613c72dba2155542295e70135f62
- https://git.kernel.org/stable/c/a7386602a2fe2f6192477e8ede291a815da09d81
- https://git.kernel.org/stable/c/abf70de2ec026ae8d7da4e79bec61888a880e00b
- https://git.kernel.org/stable/c/bf3134feffe61b7a0e21f60a04743f8da0958b53
- https://git.kernel.org/stable/c/d4f65615db7fca3df9f7e79eadf937e6ddb03c54
Get alerted when CVE-2022-49601 or the next vulnerability affects your stack