What’s Vulnerable › Vulnerabilities
CVE-2022-49602: ip: Fix a data-race around sysctl_fwmark_reflect.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ip: Fix a data-race around sysctl_fwmark_reflect. While reading sysctl_fwmark_reflect, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 3.16 before 4.9.325; from 4.10 before 4.14.290; from 4.15 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58 — fixed in 4.14.290, 4.19.254, 4.9.325, 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 4.14.290, 4.19.254, 4.9.325, 5.10.134. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ee76fe01ff3c0b4efaa500aecc90d7c8d3a8860
- https://git.kernel.org/stable/c/25a635a67c830766110410fea88ec4e6ee29684b
- https://git.kernel.org/stable/c/5e7a1be3e68deef250ad43cc91f7bb8d7d758b48
- https://git.kernel.org/stable/c/85d0b4dbd74b95cc492b1f4e34497d3f894f5d9a
- https://git.kernel.org/stable/c/9096edcf4854289f92252e086cf6e498c7f8c21d
- https://git.kernel.org/stable/c/a475ecc9ad919aa3ebdd4e4a6ee612b793bf74b3
- https://git.kernel.org/stable/c/dccf8a67f30e18980d13f07006e5a536bbd1e136
- https://git.kernel.org/stable/c/fc92e3b4bebfdd986ef1d2c5019f236837b0b982
Get alerted when CVE-2022-49602 or the next vulnerability affects your stack