What’s Vulnerable › Vulnerabilities
CVE-2022-49603: ip: Fix data-races around sysctl_ip_fwd_update_priority.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ip: Fix data-races around sysctl_ip_fwd_update_priority. While reading sysctl_ip_fwd_update_priority, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 4.19 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 5.10.134, 5.15.58, 5.18.15
How to fix
Upgrade to a fixed version: Linux kernel 5.10.134, 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/11038fa781ab916535c53351537b22d6d405667d
- https://git.kernel.org/stable/c/351f81f7d7185d18a9ff76f8f8c2fa8c4eea563b
- https://git.kernel.org/stable/c/7bf9e18d9a5e99e3c83482973557e9f047b051e7
- https://git.kernel.org/stable/c/bcc03369d3277ae075ed421f0c8bf4adb5e65b74
Get alerted when CVE-2022-49603 or the next vulnerability affects your stack