What’s Vulnerable › Vulnerabilities
CVE-2022-49604: ip: Fix data-races around sysctl_ip_fwd_use_pmtu.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ip: Fix data-races around sysctl_ip_fwd_use_pmtu. While reading sysctl_ip_fwd_use_pmtu, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 3.14 before 4.19.254; from 4.20 before 5.4.208; from 5.5 before 5.10.134; from 5.11 before 5.15.58; from 5.16 before 5.18.15; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 (+1) — fixed in 4.19.254, 5.10.134, 5.15.58, 5.18.15, 5.4.208
How to fix
Upgrade to a fixed version: Linux kernel 4.19.254, 5.10.134, 5.15.58, 5.18.15. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/60c158dc7b1f0558f6cadd5b50d0386da0000d50
- https://git.kernel.org/stable/c/7828309df0f89419a9349761a37c7d1b0da45697
- https://git.kernel.org/stable/c/93fbc06da1d819f3981a7bd7928c3641ea67b364
- https://git.kernel.org/stable/c/b96ed5ccb09ae71103023ed13acefb194f609794
- https://git.kernel.org/stable/c/e364b5f6ffbfc457a997ad09a7baa16c19581edc
- https://git.kernel.org/stable/c/eb15262128b793e4b1d1c4514d3e6d19c3959764
Get alerted when CVE-2022-49604 or the next vulnerability affects your stack