What’s Vulnerable › Vulnerabilities
CVE-2022-49629: nexthop: Fix data-races around nexthop_compat_mode.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: nexthop: Fix data-races around nexthop_compat_mode. While reading nexthop_compat_mode, it can be changed concurrently. Thus, we need to add READ_ONCE() to its readers.
Affected products
- Linux kernel: from 5.8 before 5.10.132; from 5.11 before 5.15.56; from 5.16 before 5.18.13; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 — fixed in 5.10.132, 5.15.56, 5.18.13
How to fix
Upgrade to a fixed version: Linux kernel 5.10.132, 5.15.56, 5.18.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d17723afea3ae8c9f245c9bbd2ba5945b77e812
- https://git.kernel.org/stable/c/a51040d4b120f3520df64fb0b9c63b31d69bea9b
- https://git.kernel.org/stable/c/ae3054f6fbccc90f14ecd6cf9b2c09a2401c64fd
- https://git.kernel.org/stable/c/bdf00bf24bef9be1ca641a6390fd5487873e0d2e
Get alerted when CVE-2022-49629 or the next vulnerability affects your stack