What’s Vulnerable › Vulnerabilities
CVE-2022-49631: raw: Fix a data-race around sysctl_raw_l3mdev_accept.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: raw: Fix a data-race around sysctl_raw_l3mdev_accept. While reading sysctl_raw_l3mdev_accept, it can be changed concurrently. Thus, we need to add READ_ONCE() to its reader.
Affected products
- Linux kernel: from 5.0 before 5.4.207; from 5.5 before 5.10.132; from 5.11 before 5.15.56; from 5.16 before 5.18.13; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 — fixed in 5.10.132, 5.15.56, 5.18.13, 5.4.207
How to fix
Upgrade to a fixed version: Linux kernel 5.10.132, 5.15.56, 5.18.13, 5.4.207. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/038a87b3e460d2ee579c8b1bd3890d816d6687b1
- https://git.kernel.org/stable/c/1dace014928e6e385363032d359a04dee9158af0
- https://git.kernel.org/stable/c/46e9c46203fd4676720ddca0fef7eff26826648e
- https://git.kernel.org/stable/c/ab5adca2e17d6595f3fc0e25ccb6bcbe2e01ca4f
- https://git.kernel.org/stable/c/cc9540ba5b3652c473af7e54892a48cdced87983
Get alerted when CVE-2022-49631 or the next vulnerability affects your stack