What’s Vulnerable › Vulnerabilities
CVE-2022-49634: sysctl: Fix data-races in proc_dou8vec_minmax().
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: sysctl: Fix data-races in proc_dou8vec_minmax(). A sysctl variable is accessed concurrently, and there is always a chance of data-race. So, all readers and writers need some basic protection to avoid load/store-tearing. This patch changes proc_dou8vec_minmax() to use READ_ONCE() and WRITE_ONCE() internally to fix data-races on the sysctl side. For now, proc_dou8vec_minmax() itself is tolerant to a data-race, but we still need to add annotations on the other subsystem's side.
Affected products
- Linux kernel: from 5.13 before 5.15.56; from 5.16 before 5.18.13; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 — fixed in 5.15.56, 5.18.13
How to fix
Upgrade to a fixed version: Linux kernel 5.15.56, 5.18.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/5f776daef0b5354615ec4b4234cd9539ca05f273
- https://git.kernel.org/stable/c/7dee5d7747a69aa2be41f04c6a7ecfe3ac8cdf18
- https://git.kernel.org/stable/c/e58b02e445463065b4078bf621561da75197853f
- https://git.kernel.org/stable/c/f177b382c33900d0e5a9766493c11a1074076f78
Get alerted when CVE-2022-49634 or the next vulnerability affects your stack