What’s Vulnerable › Vulnerabilities
CVE-2022-49637: ipv4: Fix a data-race around sysctl_fib_sync_mem.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: ipv4: Fix a data-race around sysctl_fib_sync_mem. While reading sysctl_fib_sync_mem, it can be changed concurrently. So, we need to add READ_ONCE() to avoid a data-race.
Affected products
- Linux kernel: from 5.2 before 5.4.207; from 5.5 before 5.10.132; from 5.11 before 5.15.56; from 5.16 before 5.18.13; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 — fixed in 5.10.132, 5.15.56, 5.18.13, 5.4.207
How to fix
Upgrade to a fixed version: Linux kernel 5.10.132, 5.15.56, 5.18.13, 5.4.207. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/190cd4ff128373271e065afb20f1d2247b3f10c3
- https://git.kernel.org/stable/c/418b191d5f223a8cb6cab09eae1f72c04ba6adf2
- https://git.kernel.org/stable/c/73318c4b7dbd0e781aaababff17376b2894745c0
- https://git.kernel.org/stable/c/7c1acd98fb221dc0d847451b9ab86319f8b9916c
- https://git.kernel.org/stable/c/9be8aac91960ea32fd0e874758c9afee665c57d2
Get alerted when CVE-2022-49637 or the next vulnerability affects your stack