What’s Vulnerable › Vulnerabilities
CVE-2022-49643: ima: Fix a potential integer overflow in ima_appraise_measurement
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-08-04
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: ima: Fix a potential integer overflow in ima_appraise_measurement When the ima-modsig is enabled, the rc passed to evm_verifyxattr() may be negative, which may cause the integer overflow problem.
Affected products
- Linux kernel: from 5.4 before 5.4.207; from 5.5 before 5.10.132; from 5.11 before 5.15.56; from 5.16 before 5.18.13; 5.19-rc1, 5.19-rc2, 5.19-rc3, 5.19-rc4, 5.19-rc5, 5.19-rc6 — fixed in 5.10.132, 5.15.56, 5.18.13, 5.4.207
How to fix
Upgrade to a fixed version: Linux kernel 5.10.132, 5.15.56, 5.18.13, 5.4.207. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/388f3df7c3c8b7f2a32b9ae0a9b2f9f6ad3b1b77
- https://git.kernel.org/stable/c/640cea4c2839a821adfbb703b590a5928abe9286
- https://git.kernel.org/stable/c/831e190175f10652be93b08436cc7bf2e62e4bb6
- https://git.kernel.org/stable/c/c8d5d81940938b5f6c0f495ca9538e7740416f30
- https://git.kernel.org/stable/c/d2ee2cfc4aa85ff6a2a3b198a3a524ec54e3d999
Get alerted when CVE-2022-49643 or the next vulnerability affects your stack