What’s Vulnerable › Vulnerabilities
CVE-2022-4967
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
Description
strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).
Affected products
- strongSwan: from 5.9.2 before 5.9.6 — fixed in 5.9.6
How to fix
Upgrade to a fixed version: strongSwan 5.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/strongswan/strongswan/commit/e4b4aabc4996fc61c37deab7858d07bc4d220136
- https://security.netapp.com/advisory/ntap-20240614-0006/
- https://www.cve.org/CVERecord?id=CVE-2022-4967
- https://www.strongswan.org/blog/2024/05/13/strongswan-vulnerability-(cve-2022-4967).html
- https://github.com/strongswan/strongswan/commit/e4b4aabc4996fc61c37deab7858d07bc4d220136
- https://security.netapp.com/advisory/ntap-20240614-0006/
- https://www.cve.org/CVERecord?id=CVE-2022-4967
- https://www.strongswan.org/blog/2024/05/13/strongswan-vulnerability-(cve-2022-4967).html
Get alerted when CVE-2022-4967 or the next vulnerability affects your stack