What’s Vulnerable › Vulnerabilities
CVE-2022-49727: ipv6: Fix signed integer overflow in l2tp_ip6_sendmsg
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-26 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: Fix signed integer overflow in l2tp_ip6_sendmsg When len >= INT_MAX - transhdrlen, ulen = len + transhdrlen will be overflow. To fix, we can follow what udpv6 does and subtract the transhdrlen from the max.
Affected products
- Linux kernel: before 4.9.320; from 4.10 before 4.14.285; from 4.15 before 4.19.249; from 4.20 before 5.4.200; from 5.5 before 5.10.124; from 5.11 before 5.15.49 — fixed in 4.14.285, 4.19.249, 4.9.320, 5.10.124, 5.15.49, 5.18.6
How to fix
Upgrade to a fixed version: Linux kernel 4.14.285, 4.19.249, 4.9.320, 5.10.124. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/034246122f5c5e2e2a0b9fe04e24517920e9beb1
- https://git.kernel.org/stable/c/0e818d433fc2718fe4da044ffca7431812a7e04e
- https://git.kernel.org/stable/c/27a37755ceb401111ded76810359d3adc4b268a1
- https://git.kernel.org/stable/c/2cf73c7cb6125083408d77f43d0e84d86aed0000
- https://git.kernel.org/stable/c/2f42389d270f2304c8855b0b63498a5a4d0c053d
- https://git.kernel.org/stable/c/6c4e3486d21173d60925ef52e512cae727b43d30
- https://git.kernel.org/stable/c/b8879ca1fd7348b4d5db7db86dcb97f60c73d751
- https://git.kernel.org/stable/c/f638a84afef3dfe10554c51820c16e39a278c915
Get alerted when CVE-2022-49727 or the next vulnerability affects your stack