What’s Vulnerable › Vulnerabilities

CVE-2022-4974: Freemius SDK <= 2.4.2 - Missing Authorization Checks

Description

The Freemius SDK, as used by hundreds of WordPress plugin and theme developers, was vulnerable to Cross-Site Request Forgery and Information disclosure due to missing capability checks and nonce protection on the _get_debug_log, _get_db_option, and the _set_db_option functions in versions up to, and including 2.4.2. Any WordPress plugin or theme running a version of Freemius less than 2.4.3 is vulnerable.

Affected products

How to fix

Upgrade to a fixed version: 5starplugins Easy Age Verify 1.6.1; 5starplugins Featured Images in RSS for Mailchimp & More 1.5.9; 5starplugins Marijuana Age Verify 1.3.1; nasirahmed AFI – The Easiest Integration Plugin 1.49.0; nasirahmed Forms to Zapier, Integromat, IFTTT, Workato, Automate.io, elastic.io, Built.io, APIANT, Webhook 1.1.9; pagup WP Google Street View (with 360° virtual tour) & Google maps + Local SEO 1.0.9; aharonyan Guest posting / Frontend Posting / Front Editor – WP Front User Submit 3.4.1; alekv Pixel Manager for WooCommerce – Conversion Tracking, Google Ads, GA4, TikTok, Dynamic Remarketing 1.14.3; alleythemes Alley Business Toolkit 1.1.8; alphabposervice Easy Code Snippets 1.0.1; alphabposervice Easy Newsletter Signups 1.0.4; alphabposervice Easy Post Views Count 1.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-4974 or the next vulnerability affects your stack