What’s Vulnerable › Vulnerabilities
CVE-2022-49743: ovl: Use "buf" flexible array for memcpy() destination
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: ovl: Use "buf" flexible array for memcpy() destination The "buf" flexible array needs to be the memcpy() destination to avoid false positive run-time warning from the recent FORTIFY_SOURCE hardening: memcpy: detected field-spanning write (size 93) of single field "&fh->fb" at fs/overlayfs/export.c:799 (size 21)
Affected products
- Linux kernel: before 5.15.93; from 5.16 before 6.1.11 — fixed in 5.15.93, 6.1.11
How to fix
Upgrade to a fixed version: Linux kernel 5.15.93, 6.1.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/012cdef22000f3104e4fa8224ad29fde509b8caf
- https://git.kernel.org/stable/c/07a96977b2f462337a9121302de64277b8747ab1
- https://git.kernel.org/stable/c/a77141a06367825d639ac51b04703d551163e36c
- https://git.kernel.org/stable/c/cf8aa9bf97cadf85745506c6a3e244b22c268d63
Get alerted when CVE-2022-49743 or the next vulnerability affects your stack