What’s Vulnerable › Vulnerabilities
CVE-2022-49755: usb: gadget: f_fs: Prevent race during ffs_ep0_queue_wait
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: usb: gadget: f_fs: Prevent race during ffs_ep0_queue_wait While performing fast composition switch, there is a possibility that the process of ffs_ep0_write/ffs_ep0_read get into a race condition due to ep0req being freed up from functionfs_unbind. Consider the scenario that the ffs_ep0_write calls the ffs_ep0_queue_wait by taking a lock &ffs->ev.waitq.lock. However, the functionfs_unbind isn't bounded so it can go ahead and mark the ep0req to NULL, and since there is no NULL check in ffs_ep0_queue_wait we will end up in use-after-free. Fix this by making a serialized execution between the two functions using a mutex_lock(ffs->mutex).
Affected products
- Linux kernel: from 2.6.35 before 4.14.305; from 4.15 before 4.19.272; from 4.20 before 5.4.231; from 5.5 before 5.10.166; from 5.11 before 5.15.91; from 5.16 before 6.1.9 — fixed in 4.14.305, 4.19.272, 5.10.166, 5.15.91, 5.4.231, 6.1.9
How to fix
Upgrade to a fixed version: Linux kernel 4.14.305, 4.19.272, 5.10.166, 5.15.91. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6a19da111057f69214b97c62fb0ac59023970850
- https://git.kernel.org/stable/c/6aee197b7fbcd61596a78b47d553f2f99111f217
- https://git.kernel.org/stable/c/6dd9ea05534f323668db94fcc2726c7a84547e78
- https://git.kernel.org/stable/c/a8d40942df074f4ebcb9bd3413596d92f323b064
- https://git.kernel.org/stable/c/ae8e136bcaae96163b5821984de1036efc9abb1a
- https://git.kernel.org/stable/c/e9036e951f93fb8d7b5e9d6e2c7f94a4da312ae4
- https://git.kernel.org/stable/c/facf353c9e8d7885b686d9a4b173d4e0af6441d2
Get alerted when CVE-2022-49755 or the next vulnerability affects your stack