What’s Vulnerable › Vulnerabilities
CVE-2022-49766: netlink: Bounds-check struct nlmsgerr creation
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: netlink: Bounds-check struct nlmsgerr creation In preparation for FORTIFY_SOURCE doing bounds-check on memcpy(), switch from __nlmsg_put to nlmsg_put(), and explain the bounds check for dealing with the memcpy() across a composite flexible array struct. Avoids this future run-time warning: memcpy: detected field-spanning write (size 32) of single field "&errmsg->msg" at net/netlink/af_netlink.c:2447 (size 16)
Affected products
- Linux kernel: before 6.0.10 — fixed in 6.0.10
How to fix
Upgrade to a fixed version: Linux kernel 6.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/710d21fdff9a98d621cd4e64167f3ef8af4e2fd1
- https://git.kernel.org/stable/c/aff4eb16f589c3af322a2582044bca365381fcd6
Get alerted when CVE-2022-49766 or the next vulnerability affects your stack