What’s Vulnerable › Vulnerabilities
CVE-2022-49768: 9p: trans_fd/p9_conn_cancel: drop client lock earlier
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-08-04
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: 9p: trans_fd/p9_conn_cancel: drop client lock earlier syzbot reported a double-lock here and we no longer need this lock after requests have been moved off to local list: just drop the lock earlier.
Affected products
- Linux kernel: from 4.9.127 before 4.9.334; from 4.14.70 before 4.14.300; from 4.18.8 before 4.19.267; from 4.20 before 5.4.225; from 5.5 before 5.10.156; from 5.11 before 5.15.80 — fixed in 4.14.300, 4.19.267, 4.9.334, 5.10.156, 5.15.80, 5.4.225
How to fix
Upgrade to a fixed version: Linux kernel 4.14.300, 4.19.267, 4.9.334, 5.10.156. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/52f1c45dde9136f964d63a77d19826c8a74e2c7f
- https://git.kernel.org/stable/c/612c977f5d481f551d03d83d0aef588845c1300c
- https://git.kernel.org/stable/c/82825dbf393f7c7979d462f9609a15bde8092b3f
- https://git.kernel.org/stable/c/96760723aae1b45f733f702abb4333137143909f
- https://git.kernel.org/stable/c/a4f1a01b2e81378fce9ca528d4d8a049e4b58fcd
- https://git.kernel.org/stable/c/e3031280fe4eaf61a09e60823331f81f321be8e1
- https://git.kernel.org/stable/c/f14858bc77c567e089965962877ee726ffad0556
- https://git.kernel.org/stable/c/fec1406f5e7ab20b71f6d231792b0040e3300aaf
Get alerted when CVE-2022-49768 or the next vulnerability affects your stack