What’s Vulnerable › Vulnerabilities
CVE-2022-49773: drm/amd/display: Fix optc2_configure warning on dcn314
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Fix optc2_configure warning on dcn314 [Why] dcn314 uses optc2_configure_crc() that wraps optc1_configure_crc() + set additional registers not applicable to dcn314. It's not critical but when used leads to warning like: WARNING: drivers/gpu/drm/amd/amdgpu/../display/dc/dc_helper.c Call Trace: <TASK> generic_reg_set_ex+0x6d/0xe0 [amdgpu] optc2_configure_crc+0x60/0x80 [amdgpu] dc_stream_configure_crc+0x129/0x150 [amdgpu] amdgpu_dm_crtc_configure_crc_source+0x5d/0xe0 [amdgpu] [How] Use optc1_configure_crc() directly
Affected products
- Linux kernel: from 6.0 before 6.0.10; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5 — fixed in 6.0.10
How to fix
Upgrade to a fixed version: Linux kernel 6.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/e7e4f77c991c9abf90924929a9d55f90b0bb78de
- https://git.kernel.org/stable/c/f67ef5aa88e3db0a13ae3befab2ddf14ac00a91c
Get alerted when CVE-2022-49773 or the next vulnerability affects your stack