What’s Vulnerable › Vulnerabilities
CVE-2022-49785: x86/sgx: Add overflow check in sgx_validate_offset_length()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: x86/sgx: Add overflow check in sgx_validate_offset_length() sgx_validate_offset_length() function verifies "offset" and "length" arguments provided by userspace, but was missing an overflow check on their addition. Add it.
Affected products
- Linux kernel: from 5.11 before 5.15.81; from 5.16 before 6.0.10; 6.1-rc1, 6.1-rc2, 6.1-rc3, 6.1-rc4, 6.1-rc5 — fixed in 5.15.81, 6.0.10
How to fix
Upgrade to a fixed version: Linux kernel 5.15.81, 6.0.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3b1c10fb754b0b67165e3f055a4208e5ba26dc89
- https://git.kernel.org/stable/c/5277e3d633a5d4157987f4aff068caa55e36db19
- https://git.kernel.org/stable/c/f0861f49bd946ff94fce4f82509c45e167f63690
Get alerted when CVE-2022-49785 or the next vulnerability affects your stack