What’s Vulnerable › Vulnerabilities
CVE-2022-4989
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-03 · updated 2026-07-17
- Weakness: CWE-1284
Description
** UNSUPPORTED WHEN ASSIGNED ** Improper Validation of Specified Quantity in Input in the ASUS AI Suite 3 driver allows a local user to access unintended memory regions via crafted IOCTL requests, leading to privilege escalation. Refer to the 'End-of-Life Notice and Driver Update for Legacy ASUS Drivers ' section on the ASUS Security Advisory for more information.
Affected products
- ASUS AI Suite 3: before v3.03.00 — fixed in v3.03.00
How to fix
Upgrade to a fixed version: ASUS AI Suite 3 v3.03.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-4989 or the next vulnerability affects your stack