What’s Vulnerable › Vulnerabilities
CVE-2022-49891: tracing: kprobe: Fix memory leak in test_gen_kprobe/kretprobe_cmd()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: tracing: kprobe: Fix memory leak in test_gen_kprobe/kretprobe_cmd() test_gen_kprobe_cmd() only free buf in fail path, hence buf will leak when there is no failure. Move kfree(buf) from fail path to common path to prevent the memleak. The same reason and solution in test_gen_kretprobe_cmd(). unreferenced object 0xffff888143b14000 (size 2048): comm "insmod", pid 52490, jiffies 4301890980 (age 40.553s) hex dump (first 32 bytes): 70 3a 6b 70 72 6f 62 65 73 2f 67 65 6e 5f 6b 70 p:kprobes/gen_kp 72 6f 62 65 5f 74 65 73 74 20 64 6f 5f 73 79 73 robe_test do_sys backtrace: [<000000006d7b836b>] kmalloc_trace+0x27/0xa0 [<0000000009528b5b>] 0xffffffffa059006f [<000000008408b580>] do_one_initcall+0x87/0x2a0 [<00000000c4980a7e>] do_init_module+0xdf/0x320 [<00000000d775aad0>] load_module+0x3006/0x3390 [<00000000e9a74b80>] __do_sys_finit_module+0x113/0x1b0 [<000000003726480d>] do_syscall_64+0x35/0x80 [<000000003441e93b>] entry_SYSCALL_64_after_hwframe+0x46/0xb0
Affected products
- Linux kernel: from 5.6 before 5.10.154; from 5.11 before 5.15.78; from 5.16 before 6.0.8; 6.1-rc1, 6.1-rc2, 6.1-rc3 — fixed in 5.10.154, 5.15.78, 6.0.8
How to fix
Upgrade to a fixed version: Linux kernel 5.10.154, 5.15.78, 6.0.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/66f0919c953ef7b55e5ab94389a013da2ce80a2c
- https://git.kernel.org/stable/c/71aeb8d01a8c7ab5cf7da3f81b35206f56ce6bca
- https://git.kernel.org/stable/c/bef08acbe560a926b4cee9cc46404cc98ae5703b
- https://git.kernel.org/stable/c/d1b6a8e3414aeaa0985139180c145d2d0fbd2a49
Get alerted when CVE-2022-49891 or the next vulnerability affects your stack