What’s Vulnerable › Vulnerabilities
CVE-2022-49903: ipv6: fix WARNING in ip6_route_net_exit_late()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ipv6: fix WARNING in ip6_route_net_exit_late() During the initialization of ip6_route_net_init_late(), if file ipv6_route or rt6_stats fails to be created, the initialization is successful by default. Therefore, the ipv6_route or rt6_stats file doesn't be found during the remove in ip6_route_net_exit_late(). It will cause WRNING. The following is the stack information: name 'rt6_stats' WARNING: CPU: 0 PID: 9 at fs/proc/generic.c:712 remove_proc_entry+0x389/0x460 Modules linked in: Workqueue: netns cleanup_net RIP: 0010:remove_proc_entry+0x389/0x460 PKRU: 55555554 Call Trace: <TASK> ops_exit_list+0xb0/0x170 cleanup_net+0x4ea/0xb00 process_one_work+0x9bf/0x1710 worker_thread+0x665/0x1080 kthread+0x2e4/0x3a0 ret_from_fork+0x1f/0x30 </TASK>
Affected products
- Linux kernel: from 2.6.26 before 4.19.265; from 4.20 before 5.4.224; from 5.5 before 5.10.154; from 5.11 before 5.15.78; from 5.16 before 6.0.8; 6.1-rc1, 6.1-rc2, 6.1-rc3 — fixed in 4.19.265, 5.10.154, 5.15.78, 5.4.224, 6.0.8
How to fix
Upgrade to a fixed version: Linux kernel 4.19.265, 5.10.154, 5.15.78, 5.4.224. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/080589287127838046077904f34d5054ea0f895c
- https://git.kernel.org/stable/c/0ed71af4d017d2bd2cbb8f7254f613a4914def26
- https://git.kernel.org/stable/c/381453770f731f0f43616a1cd4c759b7807a1517
- https://git.kernel.org/stable/c/5dbb47ee89762da433cd8458788d7640c85f1a07
- https://git.kernel.org/stable/c/768b3c745fe5789f2430bdab02f35a9ad1148d97
- https://git.kernel.org/stable/c/83fbf246ced54dadd7b9adc2a16efeff30ba944d
Get alerted when CVE-2022-49903 or the next vulnerability affects your stack