What’s Vulnerable › Vulnerabilities
CVE-2022-49935: dma-buf/dma-resv: check if the new fence is really later
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: dma-buf/dma-resv: check if the new fence is really later Previously when we added a fence to a dma_resv object we always assumed the the newer than all the existing fences. With Jason's work to add an UAPI to explicit export/import that's not necessary the case any more. So without this check we would allow userspace to force the kernel into an use after free error. Since the change is very small and defensive it's probably a good idea to backport this to stable kernels as well just in case others are using the dma_resv object in the same way.
Affected products
- Linux kernel: from 5.0 before 5.19.8; 6.0-rc1, 6.0-rc2, 6.0-rc3 — fixed in 5.19.8
How to fix
Upgrade to a fixed version: Linux kernel 5.19.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/a3f7c10a269d5b77dd5822ade822643ced3057f0
- https://git.kernel.org/stable/c/c4c798fe98adceb642050819cb57cbc8f5c27870
Get alerted when CVE-2022-49935 or the next vulnerability affects your stack