What’s Vulnerable › Vulnerabilities
CVE-2022-49967: bpf: Fix a data-race around bpf_jit_limit.
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel, the following vulnerability has been resolved: bpf: Fix a data-race around bpf_jit_limit. While reading bpf_jit_limit, it can be changed concurrently via sysctl, WRITE_ONCE() in __do_proc_doulongvec_minmax(). The size of bpf_jit_limit is long, so we need to add a paired READ_ONCE() to avoid load-tearing.
Affected products
- Linux kernel: from 4.9.190 before 4.10; from 4.14.140 before 4.15; from 4.19.47 before 5.19.8; 6.0-rc1, 6.0-rc2, 6.0-rc3 — fixed in 4.10, 4.15, 5.19.8
How to fix
Upgrade to a fixed version: Linux kernel 4.10, 4.15, 5.19.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0947ae1121083d363d522ff7518ee72b55bd8d29
- https://git.kernel.org/stable/c/ba632ad0bacb13197a8f38e7526448974e87f292
Get alerted when CVE-2022-49967 or the next vulnerability affects your stack