What’s Vulnerable › Vulnerabilities
CVE-2022-49993: loop: Check for overflow while configuring loop
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: loop: Check for overflow while configuring loop The userspace can configure a loop using an ioctl call, wherein a configuration of type loop_config is passed (see lo_ioctl()'s case on line 1550 of drivers/block/loop.c). This proceeds to call loop_configure() which in turn calls loop_set_status_from_info() (see line 1050 of loop.c), passing &config->info which is of type loop_info64*. This function then sets the appropriate values, like the offset. loop_device has lo_offset of type loff_t (see line 52 of loop.c), which is typdef-chained to long long, whereas loop_info64 has lo_offset of type __u64 (see line 56 of include/uapi/linux/loop.h). The function directly copies offset from info to the device as follows (See line 980 of loop.c): lo->lo_offset = info->lo_offset; This results in an overflow, which triggers a warning in iomap_iter() due to a call to iomap_iter_done() which has: WARN_ON_ONCE(iter->iomap.offset > iter->pos); Thus, check for negative value during loop_set_status_from_info(). Bug report: https://syzkaller.appspot.com/bug?id=c620fe14aac810396d3c3edc9ad73848bf69a29e
Affected products
- Linux kernel: before 4.9.327; from 4.10 before 4.14.292; from 4.15 before 4.19.312; from 4.20 before 5.4.274; from 5.5 before 5.10.140; from 5.11 before 5.15.64 — fixed in 4.14.292, 4.19.312, 4.9.327, 5.10.140, 5.15.64, 5.19.6
How to fix
Upgrade to a fixed version: Linux kernel 4.14.292, 4.19.312, 4.9.327, 5.10.140. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0455bef69028c65065f16bb04635591b2374249b
- https://git.kernel.org/stable/c/18e28817cb516b39de6281f6db9b0618b2cc7b42
- https://git.kernel.org/stable/c/6858933131d0dadac071c4d33335a9ea4b8e76cf
- https://git.kernel.org/stable/c/9be7fa7ead18a48940df7b59d993bbc8b9055c15
- https://git.kernel.org/stable/c/a217715338fd48f72114725aa7a40e484a781ca7
- https://git.kernel.org/stable/c/adf0112d9b8acb03485624220b4934f69bf13369
- https://git.kernel.org/stable/c/b40877b8562c5720d0a7fce20729f56b75a3dede
- https://git.kernel.org/stable/c/c490a0b5a4f36da3918181a8acdc6991d967c5f3
Get alerted when CVE-2022-49993 or the next vulnerability affects your stack