What’s Vulnerable › Vulnerabilities
CVE-2022-50012: powerpc/64: Init jump labels before parse_early_param()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: powerpc/64: Init jump labels before parse_early_param() On 64-bit, calling jump_label_init() in setup_feature_keys() is too late because static keys may be used in subroutines of parse_early_param() which is again subroutine of early_init_devtree(). For example booting with "threadirqs": static_key_enable_cpuslocked(): static key '0xc000000002953260' used before call to jump_label_init() WARNING: CPU: 0 PID: 0 at kernel/jump_label.c:166 static_key_enable_cpuslocked+0xfc/0x120 ... NIP static_key_enable_cpuslocked+0xfc/0x120 LR static_key_enable_cpuslocked+0xf8/0x120 Call Trace: static_key_enable_cpuslocked+0xf8/0x120 (unreliable) static_key_enable+0x30/0x50 setup_forced_irqthreads+0x28/0x40 do_early_param+0xa0/0x108 parse_args+0x290/0x4e0 parse_early_options+0x48/0x5c parse_early_param+0x58/0x84 early_init_devtree+0xd4/0x518 early_setup+0xb4/0x214 So call jump_label_init() just before parse_early_param() in early_init_devtree(). [mpe: Add call trace to change log and minor wording edits.]
Affected products
- Linux kernel: before 4.9.326; from 4.10 before 4.14.291; from 4.15 before 4.19.256; from 4.20 before 5.4.211; from 5.5 before 5.10.138; from 5.11 before 5.15.63 — fixed in 4.14.291, 4.19.256, 4.9.326, 5.10.138, 5.15.63, 5.19.4
How to fix
Upgrade to a fixed version: Linux kernel 4.14.291, 4.19.256, 4.9.326, 5.10.138. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/8f9357313cdcadb0a311b44c29d4eaccc7fa632f
- https://git.kernel.org/stable/c/ca829e05d3d4f728810cc5e4b468d9ebc7745eb3
- https://git.kernel.org/stable/c/e3c9e9452a8ea12d335b1e59b2c72e1b99c699b8
Get alerted when CVE-2022-50012 or the next vulnerability affects your stack