What’s Vulnerable › Vulnerabilities
CVE-2022-50030: scsi: lpfc: Prevent buffer overflow crashes in debugfs with malformed user input
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-18 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: lpfc: Prevent buffer overflow crashes in debugfs with malformed user input Malformed user input to debugfs results in buffer overflow crashes. Adapt input string lengths to fit within internal buffers, leaving space for NULL terminators.
Affected products
- Linux kernel: before 5.4.211; from 5.5 before 5.10.138; from 5.11 before 5.15.63; from 5.16 before 5.19.4 — fixed in 5.10.138, 5.15.63, 5.19.4, 5.4.211
How to fix
Upgrade to a fixed version: Linux kernel 5.10.138, 5.15.63, 5.19.4, 5.4.211. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2d544e9d19c109dfe34b3dc1253a8b2971abe060
- https://git.kernel.org/stable/c/927907f1cbb3408cadde637fccfc17bb6b10a87d
- https://git.kernel.org/stable/c/b92506dc51f81741eb26609175ac206c20f06e0a
- https://git.kernel.org/stable/c/c29a4baaad38a332c0ae480cf6d6c5bf75ac1828
- https://git.kernel.org/stable/c/f8191d40aa612981ce897e66cda6a88db8df17bb
Get alerted when CVE-2022-50030 or the next vulnerability affects your stack